VNC & X11 performance issues on AIX 7 PDF Print E-mail
User Rating: / 0
PoorBest 
Written by Ozan Uzun   
I had VNC/Display issues on AIX. Even simple xclock application response was 30+ seconds.

 

I ran two DB installations this month. Both had terrible issues. I was very unlucky and very unhappy.

The DBA called me and told me he can not install oracle. The runInstaller.sh was very slow, each screen was taking at least 35 minutes to load. Upon investigation, I found out that they played with /etc/hosts file and hostname was not "pingable"

 

Lesson 1: Always check hostname- IP Address Combination

 

Second issue was similar. DBA's (yes more than one) could not install DB again.  It was extreme slow. 

 

First they tried forwarding X11 packages,(also ssh tunneling)  after that they switched to VNC. Same performance issue.

It is an isolated system, so my support was only over the phone.   Hostname, hosts, netsvc configuration was intact.

resolv.conf was no set .  I suggested that it could be  a network problem, so they tried with a host on the same subnet. 

Everything other than the display was very fast.

 

I installed an AIX LPAR on the LAB to replicate the issue.  It did not work out.  So I started to test configration file combinations. I read every single page about  AIX&VNC on the net.The answer was not there

 

Like Sherlock Holmes said :

 

"When you have eliminated the impossible whatever remains however improbable must be the truth?"

 

We added a dummy nameserver in the /etc/resolv.conf, the issue was solved.  

 

I think the issue might related to incorrect reverse DNS records (the server IP), but I have no means to validate my theory.

 

Lesson 2:LAB env. is not equal to real env.

 

 

 
< Prev   Next >