updating to 7100-03 PDF Print E-mail
User Rating: / 0
PoorBest 
Written by Michael Felt   

I finally got around to updating my nim server to 7103 (aka 7100-03). The DVDs I had to work with are the ones that came out last year.

There are two sets of DVDs: one that is just AIX 7.1, (7103_dvd1 -> LK4T_1710_07_VOL_1 & 7103_dvd2 -> LK4T_1710_07_VOL_2) and one that is the update package (7103_upd_dvd1 -> LCD8_1512_06_VOL_1 & 7103_upd_dvd2 -> LCD8_1512_06_VOL_2). As you can see from the LCD numbers both sets are two dvd's large.

If you are going to try to order one or the other from IBM the key numbers are LCD8_1512 (AIX 7.1 update) and LK4T_1710 (AIX 7.1 base). The additional numbers _06 and _07 respectively are the number of updates published - just like other IBM publications.

Update: MUST also update using update DVDs or ssh dies!

Noteable: in the AIX 7.1 DVD set an "oldish" version of db2 is included in the ismp/ppc directory. I am hoping this is to provide db2 at no charge for AIX LDAP servers. Unusual is that this is a slightly older version (db2_09_07_00_04) of the ismp version on the AIX 6.1 extension DVD (db2_09_07_00_08).

Further, when I did a preview of the update_all from the AIX 7.1 dvd1 I got a message that I needed a requisite fileset: bos.perf.pmaix.7.1.3.0. Low and behold this fileset was included on the update dvd1
Hint: /usr/lib/instl/sm_inst bffcreate_cmd -d './7103_upd_dvd1' \ -f'bos.perf.pmaix' -t'/export/lpp/7103' '-X'

After completing the above copy to my lpp_source I was able to successfully complete a preview command:

 
...
Requisites
----------
(being installed automatically;  required by filesets listed above)
bos.perf.pmaix 7.1.3.0                      # Performance Management
...
Verifying build dates...done                  
FILESET STATISTICS
------------------
161  Selected to be installed, of which:    
161  Passed pre-installation verification 
1  Additional requisites to be automatically installed 
----
162  Total to be installed

And, so I updated and rebooted - happy me!

Update - Not so happy me! After reboot ssh would not start!

 
root@x092:[/]/usr/sbin/sshd -4 -d
OpenSSL version mismatch. Built against 90818f, you have 1000105f
 
COMMAND STATUS
Command: OK            stdout: yes           stderr: no
Before command completion, additional instructions may appear below.
[TOP]
geninstall -I "a -cgNpqwXY -J"  -Z -p  -d . -f File 2>&1
File:
dsm.core                       7.1.3.0
dsm.dsh                        7.1.3.0
openssh.base.client            6.0.0.6103
openssh.base.server            6.0.0.6103
openssh.man.en_US              6.0.0.6103
openssh.msg.en_US              6.0.0.6103
*******************************************************************************
installp PREVIEW:  installation will not actually occur.
[MORE...55]
F1=Help                        F2=Refresh                     F3=Cancel                      F6=Command
F8=Image                       F9=Shell                       F10=Exit                       /=Find
 
< Prev   Next >