httpd-2.2.31 nearly ready
Written by Michael Felt   
I have been working on this, in bits and bursts, with testing - as I package the latest releases of Apache httpd 2.4.16 and 2.2.31.
I have been quite frustrated with the previous versions - maybe because I choose the wrong MPM model. The frustration comes because the forums refused to work with my homebrew mix of php and apache httpd. However, that seems to be solved, so my confidence has gone up greatly.

OpenSSL needs to updated!

AIX 5.3 TL7 - at the lowest level has OpenSSL installed at level 0.9.8d. While the previous packages would work with that I decided to try an experiment with OpenSSL-1.0.1. The good news is that the OpenSSL binaries available via the IBM Web Packs includes a packaging of OpenSSL for AIX 5.3 that includes OpenSSL-1.0.1 (and OpenSSL-0.9.8 for the applications that still need that).

Since this works - even on AIX 5.3 - the IBM Web Pack openssl-1.0.1.514.tar.Z is the minimal level of OpenSSL that needs to be installed.

See http://www.aixtools.net/index.php/httpd-2.2 and http://www.aixtools.net/index.php/httpd-2.4 for the latest information on AIXTOOLS httpd packaging.